Написать программу для нахождения произведения двух целых чисел х и у без использования операции умножения. Паскаль
Написать программу для нахождения произведения двух целых чисел х и у без использования операции умножения. Паскаль
Ответ(ы) на вопрос:
program a1;
var x,y,s: integer;
begin
read (x,y);
write(x,'*',y,'=');
while x>0 do
begin
If ((x mod 2) <>0) then s:=s+y;
x:= x div 2;
y:=y+y;
end;
write(s);
writeln();
readln();
end.
Русский способ умножения
Не нашли ответ?
Похожие вопросы