Написать программу для Pascal Abc, решающую следующую задачу: дано трёхзначное число. Вывести число, полученное при перестановке крайних чисел исходного числа
Написать программу для Pascal Abc, решающую следующую задачу: дано трёхзначное число. Вывести число, полученное при перестановке крайних чисел исходного числа
Ответ(ы) на вопрос:
program z1;
var x:integer;
a1,a2,a3:integer;
begin
write('x=');readln(x);
a1:=x div 100;
a2:=(x div 10) mod 10;
a3:=x mod 10;
x:=a3*100+a2*10+a1;
writeln(x);
readln
end.
Не нашли ответ?
Похожие вопросы