Написать программу для Pascal. Вычислите сумму положительных и кол-во отрицательных чисел на отрезке, концы которого вводятся с клавиатуры.

Написать программу для Pascal. Вычислите сумму положительных и кол-во отрицательных чисел на отрезке, концы которого вводятся с клавиатуры.
Гость
Ответ(ы) на вопрос:
Гость
var a,b,k1,k2,s:integer;  begin  s:=0;  k1:=0;  writeln('Введите начало и конец отрезка');  read(a,b);  k2:=b-a+1;  repeat  if b<0 then break;  s:=s+b;  b:=b-1;  inc(k1);  until (b=-1) or (b=a-1);  writeln('Сумма всех целых положительных чисел на отрезке = ',s);  writeln('Количество отрицательных целых чисел = ', k2-k1);  end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы