Написать программу для решение задачи - посчитать количество чисел от 1 до 1000 кратных 7 и честных ( провереть кратность 7 командой mod введя условие если в цикл)
Написать программу для решение задачи - посчитать количество чисел от 1 до 1000 кратных 7 и честных ( провереть кратность 7 командой mod введя условие если в цикл)
Ответ(ы) на вопрос:
var
count,i:integer;
begin
i:=0;count:=0;
repeat
i:=i+2;
if i mod 7 =0 then count:=count+1;
until i>=1000;
writeln(count);
end.
var
x,i,y:integer;
begin
for i:=1 to 1000 do
begin
x:= i mod 7;
if x=0 then
begin
y:=y+1;
writeln (i);//строка выводит все числа кратные семи. она подлежит удалению
end;
end;
writeln (y);
end.
Не нашли ответ?
Похожие вопросы