Написать программу для решения следующей задачи: учебным заведением был приобретен стол за S руб. Его амортизация составляет 12% в год. Определить, сколько он будет стоить через N лет. (Pascal) Пример: Введите стоимость стола :...
Написать программу для решения следующей задачи: учебным заведением был приобретен стол за S руб. Его амортизация составляет 12% в год. Определить, сколько он будет стоить через N лет. (Pascal)
Пример:
Введите стоимость стола : 35000
Введите кол-во лет : 5
Стоимость стола на конец 1 года :30800.000рублей
Стоимость стола на конец 2 года :27104.000рублей
Стоимость стола на конец 3 года :23851.520рублей
Стоимость стола на конец 4 года :20989.338рублей
Стоимость стола на конец 5 года :18470.617рублей
Ответ(ы) на вопрос:
Гость
var years,i:integer; Ststola,a,s:real;begin writeln('Ââåäèòå ñòî-òü ñòîëà:'); readln(Ststola); writeln('Ââåäèòå êîë-âî ëåò:'); readln(years); s:=0; for i:=1 to years do begin a:=Ststola*0.12; a:=Ststola-a; Ststola:=a; Writeln('Стоимость стола через ', i, ' лет ', a); end;end.
Не нашли ответ?
Похожие вопросы