Написать программу для решения следующей задачи: в заданной числовой последовательности найти и вывести на печать номер первого отрицательного элемента. Если все элементы последовательности неотрицательны, то вывести ноль. prog...

Написать программу для решения следующей задачи: в заданной числовой последовательности найти и вывести на печать номер первого отрицательного элемента. Если все элементы последовательности неотрицательны, то вывести ноль. program lab5_5; const n=10; type x=array[1..n] of integer; var a:x; i:integer; k:integer; begin for i:=1 to n do begin a[i]:=-10+random (91); write (A[i]:4) end; writeln; k:=0; for i:=n downto 1 do if a[i]<0 then begin k:=I end; if k>0 then writeln (‘Индекс отрицательного элемента=’,k:1) else writeln (‘В массиве нет отрицательных элементов’); readln; end. как сделать эту программу без random чтоб работало в Pascal ABC?
Гость
Ответ(ы) на вопрос:
Гость
program lab5_5; const n=10; type x=array[1..n] of integer; var a:x;i,k:integer; begin for i:=1 to n do begin read(a[i]); {с вашего позволения я убрал "write (A[i]:4)" в остальном программа получает от пользователя 10 чисел и обрабатывает их} end; writeln; k:=0; for i:=n downto 1 do if a[i]<0 then begin k:=I end; if k>0 then writeln ('Индекс отрицательного элемента=',k:1) else writeln ('В массиве нет отрицательных элементов'); readln; end. 
Не нашли ответ?
Ответить на вопрос
Похожие вопросы