Написать программу, которая запрашивает кол-во сотен, кол-во десятков, кол-во един?
Написать программу, которая запрашивает кол-во сотен, кол-во десятков, кол-во един??ц, затем записывает соответствующее число, а также сумму квадратов его цифр. Сделать в программе PascalABC.NET
Ответ(ы) на вопрос:
Гость
Program test;
var
a,b,c,d,n:integer;
begin
Writeln('Введите кол-во сотен, десятков и единиц соответственно: ');
readln(a,b,c);
d:=a*100+b*10+c;
n:=sqr(a)+sqr(b)+sqr(c);
writeln('Сумма квадратов = ', n,#10, 'Само число: ',d);
end.
Не нашли ответ?
Похожие вопросы