Написать программу которая может вычислить стоимость покупки с учетом скидки 10% есть сумма покупки больше 1000р

Написать программу которая может вычислить стоимость покупки с учетом скидки 10% есть сумма покупки больше 1000р
Гость
Ответ(ы) на вопрос:
Гость
var   a: real;    begin   while a <= 1000 do   begin     writeln('Введите сумму покупки > 1000р');     readln(a);     if a > 1000 then break     else writeln('Ошибка! Введенная сумма покупки <= 1000p');   end;   writeln('Стоимость покупки с учетом скидки 10%:  ', a * 0.9); end. Данная программа проверяет, больше 1000 или нет, введенная стоимость покупки. Можно сделать проще без проверки: var   a: real;    begin   writeln('Введите сумму покупки > 1000р');   readln(a);   writeln('Стоимость покупки с учетом скидки 10%:  ', a * 0.9); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы