Написать программу, которая проверяет – образуют ли элементы заданного массива возрастающую последовательность.
Написать программу, которая проверяет – образуют ли элементы заданного массива возрастающую последовательность.
Ответ(ы) на вопрос:
var arr : array of integer; len, i : integer; begin write('Введите размер массива: '); readln(len); SetLength(arr, len); for i := 0 to len -1 do begin write('arr[', i, '] = '); readln(arr[i]); end; for i := 1 to len - 1 do if arr[i] <= arr[i - 1] then begin writeln('Последовательность не возрастающая'); Exit; end; writeln('Последовательность возрастающая'); end.
Не нашли ответ?
Похожие вопросы