Написать программу, которая заменяет все отрицательные элементы массива их модулями и выводит измененный массив на экран

Написать программу, которая заменяет все отрицательные элементы массива их модулями и выводит измененный массив на экран
Гость
Ответ(ы) на вопрос:
Гость
//прога на Pascal`e const n = 10; var a: array[0..n-1] of shortint; i: byte; begin randomize; writeln ('Исходный массив: '); for i:=0 to n-1 do begin a[i]:=random (101)-50; write (a[i], '; '); end; writeln (); writeln ('Измененный массив: '); for i:=0 to n-1 do begin a[i]:=abs (a[i]); write (a[i], '; '); end; end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы