НАПИСАТЬ ПРОГРАММУ НА PASCAL"Дана строка символов S, состоящая максимум из 250 символов. Напишите программу, которая проверит является ли строка S палиндромом. Примеры палиндромов: ‘COJOC’, ‘CAZAC’, ‘POTOP’, ‘ROTOR’."
НАПИСАТЬ ПРОГРАММУ НА PASCAL
"Дана строка символов S, состоящая максимум из 250 символов. Напишите программу, которая проверит является ли строка S палиндромом. Примеры палиндромов: ‘COJOC’, ‘CAZAC’, ‘POTOP’, ‘ROTOR’."
Ответ(ы) на вопрос:
var
s:string;
l,i:byte;
begin
readln(s);
l := length(s);
for i:= 1 to l div 2 do begin
if s[i] <> s[l-i+1] then begin
writeln('NO');
halt;
end;
end;
writeln('YES');
end.
Не нашли ответ?
Похожие вопросы