Написать программу на Паскале, используя вместо FOR - WHILE. Помогите пожалуйста!1. Напишите программу, которая в последовательности из 12 натуральных чисел определяет минимальное чётное число. Программа получает на вход натура...

Написать программу на Паскале, используя вместо FOR - WHILE. Помогите пожалуйста! 1. Напишите программу, которая в последовательности из 12 натуральных чисел определяет минимальное чётное число. Программа получает на вход натуральные числа. В последовательности всегда имеется чётное число. Введённые числа не превышают 30 000. Программа должна вывести одно число – минимальное чётное число. 2. Напишите программу, которая в последовательности из 12 натуральных чисел определяет максимальное число, оканчивающееся на 2. Программа получает на вход натуральные числа. Введённые числа не превышают30 000. Программа должна вывести одно число – максимальное число, оканчивающееся на 2.
Гость
Ответ(ы) на вопрос:
Гость
1)   var     a ,i,min: integer; begin min := 30000;  i := 0;  while i <> 12 do   begin    readln(a);    if (a 12 do  begin    readln(a);    if (a>max) and (a mod 10 = 2) then    max := a;    i := i +1;  end; writeln (max); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы