Написать программу на Паскале У меня X яблок.. Яблоко стоит E $, курс доллара к рублю p рублей за доллар.. И Y человек.. Сколько нужно яблок чтоб...

Написать программу на Паскале У меня X яблок.. Яблоко стоит E $, курс доллара к рублю p рублей за доллар.. И Y человек.. Сколько нужно яблок чтоб...Написать программу на Паскале У меня X яблок.. Яблоко стоит E $, курс доллара к рублю p рублей за доллар.. И Y человек.. Сколько нужно яблок чтобы каждому человеку досталось по 1.66 яблока, или больше, количество яблок должно быть кратно 5 (недостающие яблоки можно докупить) и сколько рублей нужно будет потратить
Гость
Ответ(ы) на вопрос:
Гость
Var    X,Y,K:integer;    E,p:real; Begin Write('Сколько яблок в наличии: ');ReadLn(X); Write('Сколько человек: ');ReadLn(Y); Write('Сколько долларов за одно яблоко: ');ReadLn(E); Write('Сколько рублей за один доллар: ');ReadLn(p); if X mod 5 <> 0 then K:=X+5-(X mod 5) else K:=X; While K/Y<1.66 do K:=K+5; WriteLn('Требуемое количество яблок: ',K); WriteLn('Столько яблок придётся докупить: ',K-X); WriteLn('Стоимость докупленных яблок: ',(K-X)*E*p:0:2,' руб.'); End. Пример: Сколько яблок в наличии: 1 Сколько человек: 3 Сколько долларов за одно яблоко: 50 Сколько рублей за один доллар: 0.05 Требуемое количество яблок: 5 Столько яблок придётся докупить: 4 Стоимость докупленных яблок: 10.00 руб.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы