Написать программу на языке C/C++, которая принимает на вход: 1. N целочисленных элементов, где N = 5 + (k mod 5). Здесь k=10. N можно задавать равным конкретному числу прямо внутри программы. 2. Целое число A (после того, как ...
Написать программу на языке C/C++, которая принимает на вход:
1. N целочисленных элементов, где N = 5 + (k mod 5). Здесь k=10.
N можно задавать равным конкретному числу прямо
внутри программы.
2. Целое число A (после того, как считали N чисел).
Найдите индекс (порядковый номер) первого числа (из введенных N чисел), равного A.
Если такого числа нет, выведите соотв. сообщение (например, “no number A”).
Написать данную программу с использованием конструкции if, цикла for, ИСПОЛЬЗУЙТЕ
массив. Использование команды goto запрещено. Подсказка: заведите целочисленный
массив, соответствующий вашему варианту задания (т.е числу N), например,
int SavedNumbers[7];
в цикле считывайте очередное целое число, пишите его в массив. После считки всех
чисел и окончания цикла считайте число A. Ещё раз пройдите по массиву и найдите
первое вхождение A, если оно есть.
Ответ(ы) на вопрос:
#include
int main() {
const int k = 10;
int n = 5 + k % 5;
int savedNumbers[n];
for (int i = 0; i < n; i++) {
scanf("%d", &savedNumbers[i]);
}
int a;
scanf("%d", &a);
for (int i = 0; i < n; i++) {
if (a == savedNumbers[i]) {
printf("First in - %d.", i + 1);
return 0;
}
}
printf("No number A.");
return 0;
}
Не нашли ответ?
Похожие вопросы