Написать программу на языке Pascal: Задача: Вводятся целые числа до первого числа, которое меньше двух. Определить, сколько простых чисел было введено. Описание переменных: q - счетчик простых чисел; n - очередное введенное чис...

Написать программу на языке Pascal: Задача: Вводятся целые числа до первого числа, которое меньше двух. Определить, сколько простых чисел было введено. Описание переменных: q - счетчик простых чисел; n - очередное введенное число. Алгоритм решения задачи: Пока введенное число больше 1, проверять его на простоту по следующему алгоритму: Если число делится на любой делитель от 2 до половины от себя, то оно не простое. Если число так и не разделилось ни на один из перебранных делителей, то оно простое, следовательно, увеличиваем счетчик простых чисел.
Гость
Ответ(ы) на вопрос:
Гость
var q,n,i,k,h:integer; begin readln(n); h:=1; while n>1 do   begin   k:=n div 2;   for i:=2 to k do     if n mod i=0 then h:=0;   q:=q+h;   h:=1;   readln(n);   end; writeln('Простых чисел: ',q) end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы