Написать программу находящую сумму , произведение , максимальные и минимальные значения из трех значений ,переменных a b c .. и блок схему
Написать программу находящую сумму , произведение , максимальные и минимальные значения из трех значений ,переменных a b c .. и блок схему
Ответ(ы) на вопрос:
Гость
#include
#include
using namespace std;
int main() {
setlocale(LC_ALL, "rus");
int a, b, c, min, max;
cout << "Введите первое число: ";
cin >> a;
cout << "Введите второе число: ";
cin >> b;
cout << "Введите третье число: ";
cin >> c;
cout << "\nСумма трех чисел равна: " << a + b + c ;
cout << "\nПроизведение трех чисел равно: " << a * b * c << endl;
if (a > b && a > c) max = a;
else if (b > a && b > c) max = b;
else if (c > a && c > b) max = c;
if (a < b && a < c) min = a;
else if (b < a && b < c) min = b;
else if (c < a && c < b) min = c;
cout << "\nМинимальное значение среди трех чисел: " << min;
cout << "\nМаксимальное значение среди трех чисел: " << max << endl;
cout << endl;
system("pause");
return 0;
}
Не нашли ответ?
Похожие вопросы