Написать программу, определяющую (отвечающею на вопрос) - больше ли числа х сумма цифр введённого числа

Написать программу, определяющую (отвечающею на вопрос) - больше ли числа х сумма цифр введённого числа
Гость
Ответ(ы) на вопрос:
Гость
var a,b,x,s:integer; begin write('a = '); readln(a); write('x = '); readln(x); b:=a; s:=0; while b>0 do  begin  s:=s+b mod 10;  b:=b div 10;  end; writeln('s = ',s); if s>x  then writeln('Сумма цифр больше ',x)  else writeln('Сумма цифр не больше ',x); end. Пример: a = 31854 x = 15 s = 21 Сумма цифр больше 15
Гость
#include #include using namespace std; int main() {     int a,x,s=0;     cin >> a >> x;     for(;abs(a)>0;s+=abs(a)%10,a/=10);     cout << (s > x ? "more" : "not more") << endl;    }
Не нашли ответ?
Ответить на вопрос
Похожие вопросы