Написать программу решения задачи: Вводить целые числа с клавиатуры, пока не будет введен ноль. а) Найти сумму введенных чисел. b) Найти количество четных отрицательных чисел среди введенных. c) Найти максимальное число среди в...

Написать программу решения задачи: Вводить целые числа с клавиатуры, пока не будет введен ноль. а) Найти сумму введенных чисел. b) Найти количество четных отрицательных чисел среди введенных. c) Найти максимальное число среди введенных.
Гость
Ответ(ы) на вопрос:
Гость
//PascalABC.Net 3.2 begin var max:=-1000000000; var sum:=0; var count:=0; var a:=0; repeat a:=readinteger('Введите число: '); if (a.IsEven) and (a<0) then inc(count); if a>max then max:=a; sum+=a; until a=0; writeln ('a) ', sum); writeln ('b) ', count); write  ('c) ', max); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы