Написать программу, в которой происходит поиск среднего арифметического в интервале от -10 до 5. Массив целочисленный из 30 элементов.

Написать программу, в которой происходит поиск среднего арифметического в интервале от -10 до 5. Массив целочисленный из 30 элементов.
Гость
Ответ(ы) на вопрос:
Гость
// PascalABC.Net 3.0, сборка 1076 begin   var a:=ArrRandom(30,-20,20);   Writeln('Исходный массив',#13#10,a);   Writeln('Среднее на [-10..5] равно ',     a.Where(x->x in [-10..5]).Average) end. Тестовое решение: Исходный массив [-17,-3,-15,0,-2,-2,-12,17,-4,20,-15,-18,-10,18,5,15,19,-6,11,19,-18,12,9,16,14,17,-20,-7,-2,16] Среднее на [-10..5] равно -3.1
Не нашли ответ?
Ответить на вопрос
Похожие вопросы