Написать программу в Pascal ABC. Последовательность чисел заканчивающихся на 0(ноль). Необходимо найти количество чисел у которых количество десятков "4" или "6".
Написать программу в Pascal ABC. Последовательность чисел заканчивающихся на 0(ноль). Необходимо найти количество чисел у которых количество десятков "4" или "6".
Ответ(ы) на вопрос:
// PascalABC.NET 3.1, сборка 1219 от 16.04.2016
var
n,k,d:integer;
begin
k:=0;
repeat
Write('Введите натуральное число, 0- завершить: ');
Read(n);
if n>0 then begin
d:=(n mod 100) div 10;
if (d=4) or (d=6) then Inc(k)
end
until n=0;
Writeln('Искомых чисел - ',k)
end.
Тестовое решение:
Введите натуральное число, 0- завершить: 345
Введите натуральное число, 0- завершить: 6285
Введите натуральное число, 0- завершить: 7854
Введите натуральное число, 0- завершить: 1324
Введите натуральное число, 0- завершить: 653
Введите натуральное число, 0- завершить: 66666
Введите натуральное число, 0- завершить: 0
Искомых чисел - 2
program random;
var a, b, c, d:integer;
begin
read (a);
if a mod 10 = 0 then writeln ('число оканчивается на ноль')
else writeln ('число оканчивается не на ноль');
end. – программа, которая высчитывает, оканчивается ли число на ноль или нет. Принцип работы:
ты вводишь число. Если число делится на 10, тогда на экран тебе выводится подтверждающая этому информация, что число оканчивается на ноль.
program random;
var a, b:integer;
begin
read (a, b); // a – десятки, b – единицы
if a = 4 or 6 then writeln ('число имеет в себе 4 десятка')
end. – программа, которая говорит тебе, имеет ли число в себе 4 или 6 десятков. Принцип работы:
ты вводишь 2 переменные: a и b; a — это десятки, а b — единицы. Если число a (десятки) равно четырём или шести, тогда на экран тебе выводится информация, подтверждающая это.
Не нашли ответ?
Похожие вопросы