Написать программу в Pascal, которая бы решала задачу: дано целое число A больше 1. Найдите наименьшое целое неотрицательное q, при котором 5^q больше A.
Написать программу в Pascal, которая бы решала задачу: дано целое число A>1. Найдите наименьшое целое неотрицательное q, при котором 5^q>A.
Ответ(ы) на вопрос:
Гость
var a,q:integer;
begin
readln(a);
for q:=1 to a do
if power(5,q)>a then
begin
write(q);
break;
end;
end.
Не нашли ответ?
Похожие вопросы