Написать программу в паскале. Дано натуральное число n (n меньше 1000) Определить: а) сколько цифр в числе б) чему равна сумма его цифр 

Написать программу в паскале. Дано натуральное число n (n<1000) Определить: а) сколько цифр в числе б) чему равна сумма его цифр 
Гость
Ответ(ы) на вопрос:
Гость
program znanijacom; uses crt; var n:string; i,k,r,c,b:integer; num:array [1..4] of char; begin writeln('vvedite celoe chislo <1000:'); read(n); k:=length(n); writeln('Cufr v chisle: ',k); for i:=1 to k do begin num[i]:=n[i]; val(num[i],c,b); r:=r+c; end; writeln('Ux cymma : ',r); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы