Написать программу в паскале для p=1*1/2*1/3...1/n и s= sqrt(1)+sqrt (1+2)+sqrt(1+3)...sqrt (1+n)

Написать программу в паскале для p=1*1/2*1/3...1/n и s= sqrt(1)+sqrt (1+2)+sqrt(1+3)...sqrt (1+n)
Гость
Ответ(ы) на вопрос:
Гость
var n,i: integer; p,s:real; begin   readln(n);   p:=1;   s:=0;   for i:=1 to n do begin      p:=p*(1/i);      if i=1 then s:=1 else s:=s+sqrt(1+i);   end;   writeln('Произведение членов 1 ряда ',p);   writeln('Сумма членов 2 ряда ',s); end.  
Не нашли ответ?
Ответить на вопрос
Похожие вопросы