Написать программу в Паскале, которая находит максимальное нечетное отрицательное число среди чисел ,уже записанных в готовом текстовом файле, и выводит результат в другой файл.

Написать программу в Паскале, которая находит максимальное нечетное отрицательное число среди чисел ,уже записанных в готовом текстовом файле, и выводит результат в другой файл.
Гость
Ответ(ы) на вопрос:
Гость
Program n1; var a,max: integer; f: text; begin assign(f,'input.txt'); reset(f); max:=0; while not eof(f) do begin read(f,a); if (abs(a)>max) and (a<0) and (a mod 2 <>0) then max:=a; end; close(f); assign(f,'output.txt'); rewrite(f); write(f,max); close(f); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы