Написать программу вывода на экран отрицательных элементов массива и суммы положительных элементов
Написать программу вывода на экран отрицательных элементов массива и суммы положительных элементов
Ответ(ы) на вопрос:
Гость
вроде так, это бэйсик
Гость
Program n1;
const n=6;
var a: array [1..n] of integer;
i,sum: integer;
begin
sum:=0;
for i:=1 to n do
begin
write('введите ',i,' число: ');
readln(a[i]);
end;
writeln('вывод отриц. элементов: ');
for i:=1 to n do
if a[i]>=0 then sum:=sum+a[i] else writeln(a[i]);
writeln('сумма положительных: ',sum);
end.
Не нашли ответ?
Похожие вопросы