Написать программу:"Дано четырехзначное число.Что больше:сумма цифр,стоящих на четных местах,или сумма цифр,стоящих на не четных местах?"

Написать программу:"Дано четырехзначное число.Что больше:сумма цифр,стоящих на четных местах,или сумма цифр,стоящих на не четных местах?"
Гость
Ответ(ы) на вопрос:
Гость
var a,s1,s2:integer; begin read (a); if (a>=1000)and (a<=9999)then begin s1:=(a mod 10) + ((a mod 1000) div 100); s2:=(a div 1000) + ((a mod 100) div 10); if (s1>s2)then writeln ('Сумма цифр,стоящих на четных местах больше суммы цифр, стоящих на нечетных местах'); if (s1
Не нашли ответ?
Ответить на вопрос
Похожие вопросы