Напишите программу для решения задачиОпределить является ли данное число n чётным двухзначным числом

Напишите программу для решения задачи Определить является ли данное число n чётным двухзначным числом
Гость
Ответ(ы) на вопрос:
Гость
var     n: integer; begin     readln(n);     writeln((n mod 2 = 0) and (n div 10 > 0) and (n div 100 = 0)); end.
Гость
Var      n,      check_n,      : integer;      flag : boolean; Begin      write('Введите чило');      readln(n);     {Проверяется, является ли n четным}      if n mod 2 = 0           then                flag = true;           else                flag = false;       {Проверяется, является ли n двухзначным}      if n div 10 <> 0           then                flag = true;           else                flag = false;      if flag           then                 writeln('Число ', n, ' является четным двухзначным');           else                writeln('Число ', n, ' не является четным двухзначным'); End.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы