Напишите программу, которая определяет, является ли введенное число простым.
Напишите программу, которая определяет, является ли введенное число простым.
Ответ(ы) на вопрос:
Гость
Var
n, i, f: integer;
begin
write('Введите число: ');
readln(n);
i:= 0; f:=0;
while i < n do
begin
i := i + 1;
if n mod i = 0 then f := f + 1;
end;
if f = 2 then writeln('Простое')
else writeln('Не простое');
end.
Не нашли ответ?
Похожие вопросы