Напишите программу, которая находит сумму четных чисел, больших 5, в последовательности целых чисел. Программа получает на выход целые числа, количество введенных чисел неизвестно, последовательность заканчивается числом 0( при...

Напишите программу, которая находит сумму четных чисел, больших 5, в последовательности целых чисел. Программа получает на выход целые числа, количество введенных чисел неизвестно, последовательность заканчивается числом 0( признак окончания ввода, не входит в последовательность). Количество чисел не превышает 100. Введенные числа по модулю не превышают 30000. Программа должна вывести одно число: сумму чётных чисел, больше 5.
Гость
Ответ(ы) на вопрос:
Гость
var     a: integer;     s: longint; begin     s := 0;     readln(a);          while a <> 0 do     begin         if (a mod 2 = 0) and (a > 5) then             s := s + a;         readln(a);     end;          writeln(s); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы