Напишите программу, которая находит сумму двузначных нечётных чисел в последовательности целых чисел. Программа получает на вход це¬лые числа, коли...

Напишите программу, которая находит сумму двузначных нечётных чисел в последовательности целых чисел. Программа получает на вход це¬лые числа, коли...напишите программу, которая находит сумму двузначных нечётных чисел в последовательности целых чисел. Программа получает на вход це¬лые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести одно число: сумму двузначных нечётных чисел в последовательности. Входные данные: 11, 15, 30, 9, 0 Выходные данные: 26.
Гость
Ответ(ы) на вопрос:
Гость
Решение фактически в один оператор // PascalABC.NET 3.2, сборка 1417 от 28.03.2017 // Внимание! Если программа не работает, обновите версию! begin   Writeln(ReadSeqIntegerWhile(n->n<>0)       .Where(n->n.IsOdd and (n>=10) and (n<=99)).Sum) end.
Гость
Var    A:integer;    S:real; Begin S:=0; Repeat Read(A); if (9 0) then S:=S+A; Until A=0; WriteLn(S) End.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы