Напишите программу, которая определяет количество различных символов, встречающихся в символьной строке. Входные данные На вход программы подаётся символьная строка. Выходные данные Программа должна вывести количество различных...
Напишите программу, которая определяет количество различных символов, встречающихся в символьной строке.
Входные данные
На вход программы подаётся символьная строка.
Выходные данные
Программа должна вывести количество различных символов в этой строке.
Примеры
входные данные
aB122AB
выходные данные
5
Pascal ABC 1.8
Ответ(ы) на вопрос:
Гость
var used: Set of Char;
s: string;
i, cnt: integer;
c: char;
begin
used := [];
readln(s);
for i := 1 to length(s) do
include(used, s[i]);
cnt := 0;
for c := #0 to #255 do
if (c in used) then
cnt := cnt + 1;
writeln(cnt);
end.
Не нашли ответ?
Похожие вопросы