Напишите программу, которая "переворачивает" заданное натуральное число.Очень нужно :с
Напишите программу, которая "переворачивает" заданное натуральное число.
Очень нужно :с
Ответ(ы) на вопрос:
Код в Паскале:
uses crt;
var n,k:integer;
begin clrscr;
write('Введите число: '); readln(n);
repeat
k:=k*10+(n mod 10);
n:=n div 10;
until(n=0);
writeln('Обратный порядок: ', k);
readln;
end.
Копировать тут(без скобок):
{ uses crt;var n,k:integer;beginclrscr;write('Введите число: '); readln(n);repeatk:=k*10+(n mod 10);n:=n div 10;until(n=0);writeln('Обратный порядок: ', k);readln;end. }
Не нашли ответ?
Похожие вопросы