Напишите программу, которая получает с клавиатуры натуральное число и определяет, сколько раз в его десятичной записи встречается цифра 1

Напишите программу, которая получает с клавиатуры натуральное число и определяет, сколько раз в его десятичной записи встречается цифра 1
Гость
Ответ(ы) на вопрос:
Гость
var n,k:integer; begin write('n = '); readln(n); k:=0; while n>0 do  begin  if n mod 10 = 1 then k:=k+1;  n:=n div 10;  end; writeln('k = ',k); end. Пример: n = 3191 k = 2
Не нашли ответ?
Ответить на вопрос
Похожие вопросы