Напишите программу, которая считывает из файла строки - каждую строку в отдельную строковую переменную, затем печатает их и их количество. Язык С++
Напишите программу, которая считывает из файла строки - каждую строку в отдельную строковую переменную, затем печатает их и их количество.
Язык С++
Ответ(ы) на вопрос:
Гость
Проверял на C++11 - работает
#include
#include
#include
#include
using namespace std;
#define FILENAME "input.txt"
int main() {
ifstream fin(FILENAME);
vector lines;
string s;
while (getline(fin, s))
lines.push_back(s);
cout << "Lines:\n";
for (int i = 0; i < lines.size(); i++)
cout << lines[i] << endl;
cout << "Count of lines: " << lines.size() << endl;
return 0;
}
Не нашли ответ?
Похожие вопросы