Напишите программу, которая в последовательности целых чисел определяет их количество и сумму четных чисел. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается ч...
Напишите программу, которая в последовательности целых чисел определяет их количество и сумму четных чисел. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0-признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30000. Программа должна вывести два числа : длину последовательности и сумму чётных чисел.
Ответ(ы) на вопрос:
Гость
program g;var sum, a, b: integer;begin b := 0; sum := 0; repeat read(a); if(a mod 2 = 0) then sum += a; if (a<>0)then b += 1; until (a = 0); write('Сумма четных чисел - ',sum,' Общее кол-во чисел - ',b)end.
Не нашли ответ?
Похожие вопросы