Напишите программу, которая вводит два вещественных числа, a и b ( a меньше b ), и выводит через пробел 5 случайных вещественных чисел в полуинтервале [ a , b ) . Входные данные Входная строка содержит два вещественных числа ...
Напишите программу, которая вводит два вещественных числа, a и b ( a < b ), и выводит через пробел 5 случайных вещественных чисел в полуинтервале [ a , b ) .
Входные данные
Входная строка содержит два вещественных числа a и b , разделённых пробелом. Гарантируется, что a < b .
Выходные данные
Нужно вывести в одной строке через пробел 5 случайных вещественных чисел в полуинтервале [ a , b ) с тремя знаками в дробной части.
Ответ(ы) на вопрос:
Гость
var a, b: real; i: integer;
begin
randomize;
readln(a,b);
for i:= 1 to 5 do
write((Random()*(b-a)+a):0:3, ' ');
end.
Не нашли ответ?
Похожие вопросы