Напишите программу которая выводит на экран (Паскаль) а)положительные числа б)отрицательные в)четные г)нечетные На заметку(числа произвольные или любые (integer))Исправлено:Даёться массив из N чисел вывести на экран количесвт...
Напишите программу которая выводит на экран (Паскаль)
а)положительные числа
б)отрицательные
в)четные
г)нечетные
На заметку(числа произвольные или любые (integer))
Исправлено:Даёться массив из N чисел вывести на экран количесвто чётных и нечётных,количество положительных и отрицательных элементов массивов
Ответ(ы) на вопрос:
const
nn = 100; { максимальное количество элементов }
var
a:array[1..nn] of integer;
i,n,k,kn,kp,ko,ke: integer;
begin
Writeln('Введите количество элементов в массиве (n<=100): ');
Readln(n);
Writeln('Введите элементы массива');
kn:=0; kp:=0; ko:=0; ke:=0;
for i := 1 to n do
begin
Read(k); a[i]:=k;
if k>0 then Inc(kp)
else if k<0 then Inc(kn);
if (k mod 2)=0 then Inc(ke) else Inc(ko)
end;
Writeln('Положительных элементов ',kp,', отрицательных ',kn);
Writeln('четных элементов ',ke,', нечетных ',ko);
end.
Тестовое решение:
Введите количество элементов в массиве (n<=100):
13
Введите элементы массива
16 -5 8 21 0 -5 13 32 7 11 -4 2 -5
Положительных элементов 8, отрицательных 4
четных элементов 6, нечетных 7
Не нашли ответ?
Похожие вопросы