Напишите программу, которая запрашивает одно целое число-номер месяца, и определяет количество дней в этом месяце. При вводе неверного месяца должно быть выведено сообщение об ошибке.
Напишите программу, которая запрашивает одно целое число-номер месяца, и определяет количество дней в этом месяце. При вводе неверного месяца должно быть выведено сообщение об ошибке.
Ответ(ы) на вопрос:
Гость
var a,b,c,d,e:real;
begin
b := 30;
c := 31;
d := 29;
e := 28;
writeln('От 1 до 12');
readln(a);
if a = 1 then writeln(c);
if a = 2 then writeln(d,' или ',e);
if a = 3 then writeln(c);
if a = 4 then writeln(b);
if a = 5 then writeln(c);
if a = 6 then writeln(b);
if a = 7 then writeln(c);
if a = 8 then writeln(c);
if a = 9 then writeln(b);
if a = 10 then writeln(c);
if a = 11 then writeln(b);
if a = 12 then writeln(c);
else writeln('Неправильно');
end.
Не нашли ответ?
Похожие вопросы