Напишите программу, которая запрашивает у пользователя число, но не больше пятизначного, и выдаёт на экран сообщение о том, сколько цифр в данном числе.0 меньше x меньше 109 меньше x меньше 99(100)

Напишите программу, которая запрашивает у пользователя число, но не больше пятизначного, и выдаёт на экран сообщение о том, сколько цифр в данном числе. 0
Гость
Ответ(ы) на вопрос:
Гость
vari,a,k,m:integer;                  begin                               Repeat                                        writeln(' ВВедите число');                                            readln(a);  k:=0;                                                  while a>0 do                                                            begin                                                                      m:=a mod 10;                                                                      k:=k+1;                                                                      a:=a div 10;                                                           end;                                           Until k<=5;                          writeln(k); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы