Напишите программу на ПАСКАЛЕ ax^2+bx+c меньше 0
Напишите программу на ПАСКАЛЕ
ax^2+bx+c<0
Ответ(ы) на вопрос:
program a1;
var a,b,c,x,x1,x2,d:real;
begin
write('Введите а '); read(a);
write('Введите b '); read(b);
write('Введите c '); read(c);
begin
d:=sqr(b)-4*a*c;
if d<0 then
begin
write('Нет корней');
end
else
begin
if d=0 then
begin
x:=-b/(2*a);
write('x=' , x);
end
else
begin
x1:=(-b+sqrt(d))/(2*a);
x2:=(-b-sqrt(d))/(2*a);
write('x1=',x1,'x2=',x2);
end;
end;
end;
end.
Не нашли ответ?
Похожие вопросы