Напишите программу пожалуйста Вася у папы силен в математике. Но сейчас папа в командировке, а Васе срочно нужно найти все решения такого уравнения: x + y + x∙y = n Поскольку Вася за долгие годы безделья разучился решать задач...
Напишите программу пожалуйста
Вася у папы силен в математике. Но сейчас папа в командировке, а Васе срочно нужно найти все решения такого уравнения:
x + y + x∙y = n
Поскольку Вася за долгие годы безделья разучился решать задачи без посторонней помощи, Вам предстоит по заданному целому n (0 ≤n≤ 109) найти количество таких пар целых неотрицательных чисел (x, y), чтобы выполнялось требуемое равенство. Поспешите, не то все узнают страшную правду о Васе.
Ответ(ы) на вопрос:
var x,y,n,col:integer;
begin
col:=0;
write('число - ');
readln(n);
for x:=0 to n do begin
for y:=0 to n do begin
if (x+y+x*y=n) then begin writeln(x,' ',y); col:=col+1; end;
end;
end;
write('количество - ',col);
end.
Не нашли ответ?
Похожие вопросы