Напишите программу в которой значение вычисляется по формуле a+b, если а- нечетное число и а*b, если а - четное число ( if a mod не равно 0)
Напишите программу в которой значение вычисляется по формуле a+b, если а- нечетное число и а*b, если а - четное число ( if a mod не равно 0)
Ответ(ы) на вопрос:
program prog
var a,b,c:integer;
begin
writeln('Введите число a,b');
readln(a,b);
if (not odd(a)) then
c:=a+b
else
c:=a*b;
writeln(c);
end.
Паскаль
var a, b: integer;
begin
read(a, b);
if odd(a) then
write(a + b)
else
write(a * b);
end.
Не нашли ответ?
Похожие вопросы