Напишите программу в паскале ABC, и нарисуйте к ней блок-схему. Вводится массив из 15 элементов,нужно определить сколько эл. массива будут между его макс и миним. элементом.

Напишите программу в паскале ABC, и нарисуйте к ней блок-схему. Вводится массив из 15 элементов,нужно определить сколько эл. массива будут между его макс и миним. элементом.
Гость
Ответ(ы) на вопрос:
Гость
var i,max,min,res,maxi,mini:integer; a: array [1..15] of integer; begin writeln('Введите числа'); for i:=1 to 15 do read(a[i]); max:=a[1]; min:=a[1]; for i:=1 to 15 do begin if maxa[i] then begin min:=a[i]; mini:=i; end; end; if maxi>mini then res:=maxi-mini else res:=mini-maxi; res:=res-2; writeln('между максимум и минимум = ', res, ' элементов'); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы