Напишите программу в ПАСКАЛЕ!!! Составьте программу, показывающую, как меняется объём вещества массой 0,45 кг при изменении его плотности от 0,5 до 1 кг/м^3 с шагом 0,1 кг/м^3.
Напишите программу в ПАСКАЛЕ!!!
Составьте программу, показывающую, как меняется объём вещества массой 0,45 кг при изменении его плотности от 0,5 до 1 кг/м^3 с шагом 0,1 кг/м^3.
Ответ(ы) на вопрос:
Гость
var p,m,v:real; i:integer;
begin
m:=0.45;
p:=0.5-0.1;
for i:=0 to round((1-0.5)/0.1) do
begin
p:=p+0.1;
v:=m/p;
writeln(p:4:1,' кг/м^3, V = ',v:5:3,' м^3');
end;
end.
Результат:
0.5 кг/м^3, V = 0.900 м^3
0.6 кг/м^3, V = 0.750 м^3
0.7 кг/м^3, V = 0.643 м^3
0.8 кг/м^3, V = 0.563 м^3
0.9 кг/м^3, V = 0.500 м^3
1.0 кг/м^3, V = 0.450 м^3
Не нашли ответ?
Похожие вопросы