Напишите программу(Паскаль), которая считывает с клавиатуры последовательность символов и выводит на экран количество нечетных цифр :с

Напишите программу(Паскаль), которая считывает с клавиатуры последовательность символов и выводит на экран количество нечетных цифр :с
Гость
Ответ(ы) на вопрос:
Гость
var n, k, a, i: integer; begin write('Введите кол-во чисел: '); readln(n); for i:=1 to n do  begin  read(a);  if ((a mod 2) = 1) then inc(k); end; write(k); end. С использованием оператора repeat: var n, k, a, i: integer; begin write('Введите кол-во чисел: '); readln(n); repeat  read(a);  if ((a mod 2) = 1) then inc(k);  inc(i);  until i=n; write(k); end.  n - кол-во чисел, k - кол-во нечётных чисел, a - число Все числа вводятся через пробел
Не нашли ответ?
Ответить на вопрос
Похожие вопросы