Напишите программу,пожалуйста После первого четного элемента вставить 0. Пример: из массива A[5]: 1 6 8 3 4 должен получиться массив A[6]: 1 6 0 8 3 4.

Напишите программу,пожалуйста После первого четного элемента вставить 0. Пример: из массива A[5]: 1 6 8 3 4 должен получиться массив A[6]: 1 6 0 8 3 4.
Гость
Ответ(ы) на вопрос:
Гость
const      n = 10;  var    a : array [1..n] of integer;  r : boolean;    i,j : integer;  begin  //Формирование массива пропущено      r := true;       While r do    begin     if a[i] mod 2 =0 then      begin       for j := n-1 downto i + 2 do         a[j] := a[j-1];        a[i+1] := 0;        r := false;      end;      i := i +1;    end;   for i := 1 to n do  writeln (a[i]);    end. Во избежании ошибок стоит учесть наличие такового элемента в массиве и размерность массива (чтобы его можно было корректно расширить на один элемент)
Не нашли ответ?
Ответить на вопрос
Похожие вопросы