Найти сумму трехзначных чисел. Использовать цикл с параметром. (Сделайте в ПАСКАЛЬ, пожалуйста)
Найти сумму трехзначных чисел. Использовать цикл с параметром.
(Сделайте в ПАСКАЛЬ, пожалуйста)
Ответ(ы) на вопрос:
Program Сумма;
var
otvet:String;
sled:= true;
chislo:=0;
i,b, summa:integer;
Begin
Write('Сколько чисел вы хотите суммировать?');
Read(b);
for i:=1 to b do
Begin
Write('Введите трёхзначное число: ');
Read(chislo);
while (chislo <100) or (chislo >1000) do
Begin
Write('Число не трёхзначное, попробуйте ещё раз!');
Read(chislo);
End;
summa+=chislo;
End;
Write('Сумма равна ', summa);
End.
Не нашли ответ?
Похожие вопросы