Необходимо написать программу на языке pascal Задан двумерный массив целых чисел размером n*m Поменять местами в каждом столбце первый элемент с первым максимальным---алгоритм на фото
Необходимо написать программу на языке pascal
Задан двумерный массив целых чисел размером n*m
Поменять местами в каждом столбце первый элемент с первым максимальным
---
алгоритм на фото
Ответ(ы) на вопрос:
Гость
const
nn=50; { максимально возможное кол-во строк }
mm=50; { максимально возможное кол-во столбцов }
var
a:array[1..nn,1..mm] of integer;
i,j,m,n,imax,t:integer;
begin
Write('Количество строк в массиве: '); Read(n);
Write('Количество столбцов в массиве: '); Read(m);
Writeln('Вводите элементы массива');
for i:=1 to n do
for j:=1 to m do Read(a[i,j]);
for j:=1 to m do begin
imax:=1;
for i:=2 to n do
if a[i,j]>a[imax,j] then imax:=i;
if i<>1 then begin
t:=a[1,j]; a[1,j]:=a[imax,j]; a[imax,j]:=t
end
end;
Writeln('Результат');
for i:=1 to n do begin
for j:=1 to m do Write(a[i,j]:3);
Writeln
end
end.
Не нашли ответ?
Похожие вопросы