Нужно написать программу на языке Паскаль, которая будет убирать из строки все символы кроме цифр. Пример: входной- a3f4h5k2 выходной:3452

Нужно написать программу на языке Паскаль, которая будет убирать из строки все символы кроме цифр. Пример: входной- a3f4h5k&2 выходной:3452
Гость
Ответ(ы) на вопрос:
Гость
var s:string; l,i:longint; begin read(s); l:=length(s); for i:=1 to l do if (s[i]>='0')and(s[i]<='9') then write(s[i]); end.
Гость
// PascalABC.NET 3.1, сборка 1172 от 19.02.2016 begin   var s:=ReadlnString;   s:=s.Where(d->d in ['0'..'9']).JoinIntoString('');   Writeln(s) end. Тестовое решение: a3f4h5k&2 3452
Не нашли ответ?
Ответить на вопрос
Похожие вопросы