Нужно написать программу в С++ по заданной функции. Основу я написал, но я не знаю, как доделать ее до конца, помогите пожалуйста! Возможно формула arcctang не та, может еще чего... Номер задания 18, я сделал мини скриншот, что...
Нужно написать программу в С++ по заданной функции.
Основу я написал, но я не знаю, как доделать ее до конца, помогите пожалуйста!
Возможно формула arcctang не та, может еще чего...
Номер задания 18, я сделал мини скриншот, чтобы вам было удобнее.
В заранее спасибо !!!
Ответ(ы) на вопрос:
#include
#include "math.h"
#include
using namespace std;
int main()
{
float x, e, xn, an, y;
int n;
cin >> x;
e = 0.0001;
n = 0;
xn = x;
an = x;
y = x;
while(abs(an)>e)
{
n = n+1;
xn = -xn*x*x;
an = xn/(2*n+1);
y = y+an;
}
y = 3.14159/2 - y;
cout << y << endl;
cout << (3.14159/2-atan(x));
system("pause");
return 0;
}
Не нашли ответ?
Похожие вопросы